Static Route Leaking between VRFs

ISP Config

vrf definition VPN1
 !
 address-family ipv4
 exit-address-family
!
vrf definition VPN2
 !
 address-family ipv4
 exit-address-family
!
interface GigabitEthernet0/1
 vrf forwarding VPN1
 ip address 1.1.1.1 255.255.255.0
!
interface GigabitEthernet0/2
 vrf forwarding VPN2
 ip address 2.1.1.1 255.255.255.0
!
ip route 1.1.1.2 255.255.255.255 GigabitEthernet0/1
ip route 2.1.1.2 255.255.255.255 GigabitEthernet0/2
ip route vrf VPN1 10.0.0.0 255.255.255.252 1.1.1.2
ip route vrf VPN1 10.0.1.0 255.255.255.252 1.1.1.2
ip route vrf VPN1 10.0.2.0 255.255.255.252 1.1.1.2
ip route vrf VPN1 10.0.3.0 255.255.255.252 1.1.1.2
ip route vrf VPN1 20.0.0.0 255.255.0.0 2.1.1.2 global
ip route vrf VPN2 10.0.0.0 255.255.0.0 1.1.1.2 global
ip route vrf VPN2 20.0.0.0 255.255.255.252 2.1.1.2
ip route vrf VPN2 20.0.1.0 255.255.255.252 2.1.1.2
ip route vrf VPN2 20.0.2.0 255.255.255.252 2.1.1.2
ip route vrf VPN2 20.0.3.0 255.255.255.252 2.1.1.2
!
 

VPN1 Configs

interface Loopback0
 ip address 10.0.0.1 255.255.255.252
!
interface Loopback1
 ip address 10.0.1.1 255.255.255.252
!
interface Loopback2
 ip address 10.0.2.1 255.255.255.252
!
interface Loopback3
 ip address 10.0.3.1 255.255.255.252
!
interface GigabitEthernet0/0
 ip address 1.1.1.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 1.1.1.1
 

VPN2 Configs


interface Loopback0
 ip address 10.0.0.1 255.255.255.252
!
interface Loopback1
 ip address 10.0.1.1 255.255.255.252
!
interface Loopback2
 ip address 10.0.2.1 255.255.255.252
!
interface Loopback3
 ip address 10.0.3.1 255.255.255.252
!
interface GigabitEthernet0/0
 ip address 1.1.1.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 1.1.1.1
 

Fast Configs

Cisco IOS
IOS base config
IOS VS IOS XE
OSPF
EIGRP
BGP
Layer 2
STP
Firewall
ASA NAT
ASA Static Route
ASA Initial Configs